Installing Canon Pixma iP1880 in Ubuntu 8.10

If you are running Ubuntu 8.10 Linux and going to connect your Canon Pixma iP1880 printer, then it is not yet plug and play.

Canon provide driver for linux. But they have not yet provided driver for Ubuntu 8.10. The good news is someone has provided us driver for Ubuntu 8.10.

Download 2 files from this links:

http://nko.computers.googlepages.com/cnijfilter-ip1800_2.70-2_i386-hardy..deb http://nko.computers.googlepages.com/cnijfilter-common_2.70-2_i386.deb

Before you install it, you need to make soflink from cups to cupsys. To do this, open a terminal (Applications-Accessories-Terminal) and give the command.

sudo ln -s /etc/init.d/cups /etc/init.d/cupsys

After you have installed two files from above links. Now you can install your printer as normal under administration ⟶ printing.